Posts Tagged 访问

Tenacy VPN 【02.01】公告

Posted by on 星期四, 2 二月, 2012

【02.01】由於 Twitter 為進入某些新興國家,增加內容審查機制,Tenacy 正在考慮放棄 Twitter 作為官方公佈最新網址的方式,請各愛用者留意。

Tenacy 依然没有发布新的访问网址,访问Tenacy依然使用:http://tenacy.dynet.com

如果访问不到的话,请试着在C:\Windows\system32\drivers\etc\hosts文件中加入一行:

173.201.244.62 tenacy.dynet.com

以便将tenacy.dynet.com解析到正确的IP地址上。

Tenacy VPN 【01.05 通告】

Posted by on 星期六, 7 一月, 2012

【01.05 通告】由於未知原因,Tenacy 已經將官方網站,變更至http://tenacy.dynet.com 。目前 Tenacy 正在調查 ESET 防病毒軟體報告 Tenacy 有危險的原因,但初步判定網站安全並未受影響,請愛用者留意。謝謝。

請您將 DNS 更換為 GOOGLE 的 8.8.8.8 與 8.8.4.4,這樣就能解決您不能打開 Tenacy 官方網站的問題。謝謝。

Tenacy VPN 的通告

Posted by on 星期六, 17 十二月, 2011

 

【12.15 通告】由於未知原因,Tenacy 的官方網站今日在(中)餪(国)部份地區出現無法訪問現象。通過緊急預案,Tenacy 已經將網站的網址更改至: http://tenacy.bd.to/ 。用於自動轉向的tenacy .biz 宣告失效。如有不便,敬請諒解。

好一个“由于未知原因”,好一个“在(中)豔(国)地区”。河蟹的力量之大、河蟹的速度之快,不得不让人赞叹佩服啊!可是网速怎么就不见快呢?

Tenacy VPN 最新地址:http://www.awolf.net/content/network/last-tenacy-vpn-address.html

如何获得TenacyVPN最新可用地址:http://www.awolf.net/content/network/how-to-get-lastest-tenacy-vpn-address.html

RouterOS DNS劫持

Posted by on 星期日, 22 五月, 2011

RouterOS DNS劫持

  • 什么是DNS劫持

  DNS劫持就是通过技术手段,来控制用户解析域名的IP地址。举个例子,正常解析域名www.awolf.net时应该返回IP:64.64.30.60;但现在通过DNS劫持,使域名www.awolf.net解析返回IP:1.1.1.1,以达到控制www.awolf.net该域名,进而控制访问www.awolf.net所打开页面。这就是DNS劫持。

  • 为什么要做DNS劫持

  有了DNS劫持,我们就可以随意控制路由器下游用户的域名解析,从而达到限制、强制访问某些网站;或者在用户访问不存在的网站时给予友好的提示;或者把IIS上多个站点用主机头区分……

  • 如何在Ros上做DNS劫持

  在ROS上,可以通过对53端口的UDP访问进行dst-nat,to-address指向我们自己的dns服务器或如果Ros开启DNS服务,也可以指向Ros本身。

WinBox设置:

  本例中使用ROS自带的DNS服务,ROS IP为192.168.27.254。

  首先开启ROS的DNS服务:Winbox中选IP->DNS,在Static页面中点Settings,按下图设置,其中202.96.64.68和202.96.69.38按你所在地区和ISP的DNS填写。

DNS设置

确定后在Winbox中选IP->Firewall,选NAT页面,点红色加号“+”,按下图设置:

Chian=dstnat,Protocol=UDP,Dst.Port=53,Action=dst-nat,To Address=192.168.27

General页设置

 

Action页设置

命令行设置:

/ip firewall nat

add action=dst-nat chain=dstnat disabled=no dst-address-type=!local dst-port=53 protocol=tcp to-addresses=192.168.0.1 to-ports=53

add action=dst-nat chain=dstnat disabled=no dst-address-type=!local dst-port=53 protocol=udp to-addresses=192.168.0.1 to-ports=53

/ip dns

set allow-remote-requests=yes cache-max-ttl=1w cache-size=4096KiB max-udp-packet-size=512 primary-dns=202.96.64.68 secondary-dns=202.96.69.38

设置成功的Firewall->Connections效果图:

DNS劫持效果图

可以看到去往202.96.64.68的DNS请求都被192.168.27.254回应了。

注意:如果要使用内网服务器做域名解析服务,必须在以上DNS劫持设置规则之上再添加一条允许该服务器访问外网DNS的规则,否则连内网DNS服务器的解析请求都被劫持了,就无法正常进行域名解析了。

例如内网DNS服务器IP是192.168.27.1,则需要在DNS劫持规则之上添加如下规则:

/ip firewall nat

add action=accept chain=dstnat disabled=no dst-port=53 protocol=udp src-address=192.168.27.1

排除DNS劫持