Posts Tagged Cisco

Cisco 产品命名规则

Posted by on 星期日, 25 十二月, 2011

 Cisco 产品命名规则:

  1. CISCO开头的产品都是路由器;

  2. RSP开头的都是CISCO7500系列产品的引擎;

  3. VIP开头的产品都是CISCO 7500系列产品的多功能接口处理器模块

  4. PA开头的产品都是CISCO 7500/7200系列产品的模块.

  5. NPE开头的都是CISCO7200系列产品的引擎;

  6. NM开头的都是CISCO低端路由器模块;

  7. WIC开头的都是CISCO低端路由器的广域网接口模块;

  8. VWIC开头的都是CISCO低端路由器的语音接口模块;

  9. WS-C开头的产品都是交换机;

  10. WS-X开头的产品是交换机的引擎或模块;

  11. WS-G开头的产品是交换机的千兆光纤模块.

  对于交换机,NN 是交换机的系列号,XX 对于固定配置的交换机来说是端口数,对于模块化交换机来说是插槽数,有 -C 标志表明带光纤接口,-M 表示模块化,-A 和-EN 分别是指交换机软件是标准板或企业版。

  eg:WS-C3750G-48TS-S

  C3750表明这款产品属于3750这个系列,也就是产品的型号。

  G—-表明其所有接口都是支持千兆或以上,如果没有这个就表明其主要端口都是10/100M的或者100M的

  48—-表明其拥有主要的端口数量为48个

  T—-表明其主要端口是电口(也就是所谓的Twirst Pair的端口

  P—-表明其主要端口是电口,同时支持PoE以太网供电

  S—-表明其带的扩展的接口为SFP类型的接口

  最后部分的S表明交换机带的软件是SMI映像,E表明是EMI映像

Cisco Catalyst交换机手册

Posted by on 星期五, 22 四月, 2011

Cisco 文档首页:http://www.cisco.com/cisco/web/support/index.html

Cisco Catalyst交换机手册:


如何在Cisco设备上配置NAT(NAT Overloading)

Posted by on 星期三, 24 十一月, 2010

  在网上看到一个Cisco的NAT设置,感觉不错,搜藏+翻译了一下。

  原文地址:http://www.itsyourip.com/cisco/how-to-configure-nat-in-cisco-ios-nat-overload

  NAT,网络地址转换,简单地把一个地址转换成另外一个地址。NAT有以下几种不同的工作方式:

  • Static NAT (一对一)
  • Dynamic NAT (多对多)
  • Overloading (多对一)

  我们重点看一下Overloading NAT,即多对一NAT。有时也称作PAT(Port Address Translation,端口地址转换)或NAPT(Network Address Port Translation,网络地址端口转换)。Overloading NAT,把多个LAN的私有地址转换成合法的公网地址。这种情况下源地址和源端口被转换成公网IP和不同的源端口。

  典型的网络应用是,在一个互联网的路由器上,把LAN所有的主机通过一个公网IP连接到互联网上。

  下面这些步骤将帮助你在Cisco的设备上配置NAT Overload或者PAT:

  1.设置NAT inside(内部)接口

把接口配置一个IP,并作为NAT inside接口。这个接口将连接你的内部私有网络

WANRouter(config)# int fastethernet0/1
WANRouter(config-if)# ip address 192.168.1.1 255.255.255.0
WANRouter(config-if)# ip nat inside

  2.设置NAT outside(外部)接口

WANRouter(config)# int serial0/0/0
WANRouter(config-if)# ip address 218.25.169.2 255.255.255.0
WANRouter(config-if)# ip nat outside

  3.配置 NAT 地址池

这个地址池是从ISP处购买的公网合法的IP地址池,可以是一个或多个地址。

WANRouter(config)# ip nat pool WANPOOL 218.25.169.2 218.25.169.2 netmask 255.255.255.0

这将创建个只有一个IP地址的地址池。

ip nat pool命令语法如下:

ip nat pool <pool name> startip endip {netmask netmask | prefix prefix-length}

  4.用访问控制列表设置可以被NAT转换的私有地址

WANRouter(config)# ip access-list 10 permit 192.168.1.0 0.0.0.255

如果有更多的网络或主机需要NAT,只需将他们逐个添加到访问控制列表

WANRouter(config)# ip access-list 10 permit 192.168.2.0 0.0.0.255
WANRouter(config)# ip access-list 10 permit 192.168.3.0 0.0.0.255

指定路由器按访问控制列表和NAT地址池进行网络地址转换

WANRouter(config)# ip nat inside source list 10 pool WANPOOL overload

如果这个路由器连接到互联网,确保有一条默认路由指向外部接口或公网IP

WANRouter(config)# ip route 0.0.0.0. 0.0.0.0 serial0/0/0

或者

WANRouter(config)# ip route 0.0.0.0 0.0.0.0 100.100.100.100

  NAT设置至此全部完成。我们已经成功的设置路由器把LAN私有IP地址转换成互联网公网IP地址。

  查看NAT状态和统计:

WANRouter# show ip nat statistics

  查看当前活动的NAT项目:

WANRouter# show ip nat translations

Cisco 2651路由器端口映射

Posted by on 星期四, 19 八月, 2010

今天给Cisco 2651路由器做了端口映射,将命令行收藏了

ip nat inside source static <协议> <内网地址> <内网端口> <接口或IP> <映射端口>

ip nat inside source static tcp 192.168.1.2 80 202.99.220.130 80



ws-c2950g-48-EI 端口镜像(分析端口)

Posted by on 星期日, 15 八月, 2010

  今天研究在cisco 2950上做了个端口分析,用于抓包。同时想到锐捷CLI与Cisco基本一致,所以经过试验,在锐捷2724G上成功执行并创建分析(镜像)端口,用于接网吧的绿网(下例中绿网接在分析端口,也就是f0/48口上),如果是千兆口,将f0/48 中的f换成g,即gigabitEthernet,如g0/48。

  以下红色部分为输入部分。

sw_wolf#conf t
Enter configuration commands, one per line. End with CNTL/Z.
sw_wolf(config)#monitor session 1 destination interface f0/48 !设置分析端口
sw_wolf(config)#monitor session 1 source interface f0/1 – 47 !设置被监控端口,注意“-”符两边有空格。
sw_wolf(config)#^Z
sw_wolf#show monitor !验证结果
Session 1
———
Type : Local Session
Source Ports :
Both : Fa0/1-47
Destination Ports : Fa0/48
Encapsulation : Native
Ingress: Disabled